adiary 関連ライブラリ

はてブ数 2023/12/14 15:35 OS別::Linuxその他::技術情報
Raspberry Pi を利用したウェブサーバで adiary を利用する際、あると便利なライブラリが存在します。
そのライブラリに関連するパッケージをインストールします。

対象は、Raspbian GNU/Linux 12 (bookworm) になります。

必須パッケージ

adiary の動作に必要なパッケージをインストールします。
$ sudo apt install perl

指定ライブラリ

adiary を便利に使うために adiary が指定するライブラリをパッケージでインストールします。

Image::Magick (PerlMagic)

存在すれば adiary 内で画像縮小が可能です。
$ sudo apt install perlmagick

Net::SSLeay

外部サイトへの https 通信に必要です。
$ sudo apt install libnet-https-any-perl

CryptX

adiary の push 通知プラグインで使用します。
$ sudo apt install libcryptx-perl

目的によるインストール

当手順では使用しませんが、必要があれば利用することになるためインストール手順を記載します。

git

公式サイトから git でインストールする際に利用します。
$ type git > /dev/null 2>&1 || sudo apt install git

確認方法

パッケージ

$ sudo apt list perl

ライブラリ

$ sudo apt list perlmagick libnet-https-any-perl libcryptx-perl

git

$ sudo apt list git